CCDV Message Board CCDV Message Board

Go Back   CCDV Message Board > Corvette Discussion > Tech Talk Ask "Slapshot" > C2 Specific Tech Talk

C2 Specific Tech Talk 1963 - 1967


Post New Thread Closed Thread
 
Thread Tools
Old 07-04-09, 10:22 AM   #1
peter711
Probationary Member
 
Join Date: Jul 2009
Posts: 2
peter711 is on a distinguished road
rough idle

I have a 66 427 390hp 4-sp. When the car is cold it runs perfect but as soon as the engine and components get to its full oper. temp the idle gets rough, fluctuates and misses. Could the problem be the coil or the ballast res. i checked both with a meter and the resistor was 1.8 cold and 2.4 when hot, do you have any suggestions.
peter711 is offline  
Old 07-04-09, 12:08 PM   #2
Bob Weiss
CCDV Club Member
 
Bob Weiss's Avatar
 
Join Date: Mar 2001
Posts: 2,830
Bob Weiss is an unknown quantity at this point
How are the points?? My 67 427/390 4 spd tends to burn points fairly quickly. Distributor Cap? Could it be the warm idle circiut in the Carb (is the choke coming off all the way) ? How does it run under power (not Idle) when hot? How old are the plug wires? So many questions !!

Bob
__________________
Bob Weiss
CCDV Past Pres.(1993, 94 & 95), Past Board Chairman
CECF President
NCM Founding Member and Past Ambassador
CCDV Life Member
Bob Weiss is offline  
Old 07-04-09, 12:26 PM   #3
peter711
Probationary Member
 
Join Date: Jul 2009
Posts: 2
peter711 is on a distinguished road
rough idle

It has new points done to specs, good cap and rotor, new adv springs, working vac. adv., timing at 4 btc, choke is off fully, new shielded wires, new plugs, rebuilt carb around 1000 miles (holley 650 double pumper w/elec. choke ) misses on hard acceleration
peter711 is offline  
Post New Thread Closed Thread

Tags
idle, rough


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My 91 runs rough in "drive" tinman332 C4 Specific Tech Talk 1 05-21-07 05:41 PM
VIDEO + SOUND : idle, revs inboard, music from the outside, cruise in 6th of my Z06 a miami993c297 General Discussions 4 02-23-05 01:03 AM


All times are GMT -4. The time now is 01:41 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.